Skip to Main Content
Cloud Platform


This is an IBM Automation portal for Cloud Platform products. To view all of your ideas submitted to IBM, create and manage groups of Ideas, or create an idea explicitly set to be either visible by all (public) or visible only to you and IBM (private), use the IBM Unified Ideas Portal (https://ideas.ibm.com).


Shape the future of IBM!

We invite you to shape the future of IBM, including product roadmaps, by submitting ideas that matter to you the most. Here's how it works:

Search existing ideas

Start by searching and reviewing ideas and requests to enhance a product or service. Take a look at ideas others have posted, and add a comment, vote, or subscribe to updates on them if they matter to you. If you can't find what you are looking for,

Post your ideas
  1. Post an idea.

  2. Get feedback from the IBM team and other customers to refine your idea.

  3. Follow the idea through the IBM Ideas process.


Specific links you will want to bookmark for future use

Welcome to the IBM Ideas Portal (https://www.ibm.com/ideas) - Use this site to find out additional information and details about the IBM Ideas process and statuses.

IBM Unified Ideas Portal (https://ideas.ibm.com) - Use this site to view all of your ideas, create new ideas for any IBM product, or search for ideas across all of IBM.

ideasibm@us.ibm.com - Use this email to suggest enhancements to the Ideas process or request help from IBM for submitting your Ideas.


Status Not under consideration
Created by Guest
Created on Jun 11, 2021

Add support for com.ibm.mq.cfg.jmqi.useMQCSPauthentication in WAS 8.5.5.X

Currently the MQ RAR packaged with WAS 8.5.5.X is too old to support com.ibm.mq.cfg.jmqi.useMQCSPauthentication. This means that for anyone who is unable to move to WAS 9 any MQ connection is required to use far less secure passwords.

Idea priority High
  • Admin
    Graham Charters
    Aug 27, 2021

    Thank you for the suggestion. The requirement does have merit, but this capability is only be enabled in MQ JMS 2.0. We are not able to support JMS 2.0 in 8.5.5.X as this would cause migration issues. We therefore recommend migrating to WAS 9.0.5.X to get this support. If you would like to discuss this decision further, please contact Graham Charters <charters@uk.ibm.com>.