Cloud Platform

Shape the future of IBM!

We invite you to shape the future of IBM, including product roadmaps, by submitting ideas that matter to you the most. Here's how it works:

Post your ideas

Start by posting ideas and requests to enhance a product or service. Take a look at ideas others have posted and upvote them if they matter to you,

  1. Post an idea

  2. Upvote ideas that matter most to you

  3. Get feedback from the IBM team to refine your idea

Help IBM prioritize your ideas and requests

The IBM team may need your help to refine the ideas so they may ask for more information or feedback. The offering manager team will then decide if they can begin working on your idea. If they can start during the next development cycle, they will put the idea on the priority list. Each team at IBM works on a different schedule, where some ideas can be implemented right away, others may be placed on a different schedule.

Receive a notification on the decision

Some ideas can be implemented at IBM, while others may not fit within the development plans for the product. In either case, the team will let you know as soon as possible. In some cases, we may be able to find alternatives for ideas which cannot be implemented in a reasonable time.

If you encounter any issues accessing the Ideas portals, please send email describing the issue to ideasibm@us.ibm.com for resolution.

For more information about IBM's Ideas program visit ibm.com/ideas.

Status Future consideration
Workspace Rational Other
Categories Synergy
Created by Guest
Created on Oct 27, 2020

Update to Eclipse Product to work with Synergy 7.2.2

We want to close the current ticket we have now with IBM to fix the Eclipse Mars plugin because this is a very old release and will not help us much
we request IBM to have the new Synergy version 7.2.2 work with newer Eclipse versions.
We are interested in having it working on 64 bit Eclipse version 2020.06 (we don't use 32bit versions)

We are using other Eclipse plugins, for instance Checkmarx that works with Eclipse 2020.06 version and we think having Synergy plugin for version 7.2.2 working with Eclipse 2020.06 version will help us with our development.

Our developers don't want to go back to Oxygen version, so we'll appreciate very much having support for newer Eclipse versions since we think that if they can offer support for Oxygen making it work with newer Eclipse, like 2020.06 will not be that complicated and it's a reasonable request.

Use Case
We have developers using Eclipse for automated configuration for development, but cannot use it for Synergy because of level mismatch between Java & Synergy.
RFE ID 146305
RFE URL
RFE Product Rational Synergy
Idea Priority High
  • Guest
    Nov 2, 2020

    Please be aware, that Eclipse 2020-06 is the last version of eclipse, which works with Java 8.
    Starting with Eclipse 2020-09 Java 11 is required.