Cloud Platform

Shape the future of IBM!

We invite you to shape the future of IBM, including product roadmaps, by submitting ideas that matter to you the most. Here's how it works:

Post your ideas

Start by posting ideas and requests to enhance a product or service. Take a look at ideas others have posted and upvote them if they matter to you,

  1. Post an idea

  2. Upvote ideas that matter most to you

  3. Get feedback from the IBM team to refine your idea

Help IBM prioritize your ideas and requests

The IBM team may need your help to refine the ideas so they may ask for more information or feedback. The offering manager team will then decide if they can begin working on your idea. If they can start during the next development cycle, they will put the idea on the priority list. Each team at IBM works on a different schedule, where some ideas can be implemented right away, others may be placed on a different schedule.

Receive a notification on the decision

Some ideas can be implemented at IBM, while others may not fit within the development plans for the product. In either case, the team will let you know as soon as possible. In some cases, we may be able to find alternatives for ideas which cannot be implemented in a reasonable time.

If you encounter any issues accessing the Ideas portals, please send email describing the issue to ideasibm@us.ibm.com for resolution.

For more information about IBM's Ideas program visit ibm.com/ideas.

Status Future consideration
Workspace Rational Other
Categories Synergy
Created by Guest
Created on May 19, 2020

Synergy Integration support of recent Eclipse versions (64bit)

Hello Synergy development,

our developers always tend to use the latest Version of Eclipse and they have to use a 64bit Version.

Please provide a Synergy Integration for a recent Eclipse 64bit Version (for example 2019-12 or newer).

We noticed an incompatibility with the IBM JRE 8.0.5.41 and Eclipse 2019-06 and later 64 Bit versions .

As soon as you click on "open catalog" (Window>Preferences>Maven>Discovery>Open Catalog) an error message "Failed to discover all connectors" appears (screenshot 20200505_Maven_Dicovery_m2e catalog_1.jpg) .

(Correctly it should look like screenshot 20200505_Maven_Dicovery_m2e catalog_2.jpg.)

It works the way it's supposed to work until Eclipse Oxygen 3a (+IBM JRE 8.0.5.41), but from Eclipse 2019-06 64-Bit and following releases, it only works with the standard JRE. Unfortunately you don´t get a connection to a Synergy database with Synergy Integration using the Standard JRE.

Therefore it is important that a upcoming Versions of the IBM JRE must also be supported with newer Eclipse 64-bit Versions, so that Maven Discovery and Synergy Integration could be used simultaneously in Eclipse 64-bit Versions.

Use Case
Using the latest Version Version of an IDE in combination with an Integration SCM Tool (Synergy). The latest supported Eclipse Version is Oxygen 3a. It is three years old and quite outdated.
RFE ID 142490
RFE URL
RFE Product Rational Synergy
Idea Priority High
  • Guest
    May 19, 2020

    Attachment (Description)

  • Guest
    May 19, 2020

    Attachment (Description)